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Quick Start Guide:

1. Go to File > Make a Copy

2. Edit to your heart’s content!

OR

1. Go to File > Download As > Microsoft Word

2. Save the file and edit away!

How to Use This Template to Write Your
Marketing Plan
So it’s time to write a marketing plan! This template will get you started — and get the
job done. It includes all the major sections you’ll need for a complete digital
marketing plan.

● Business Summary
● Executive Summary
● Business Goals
● Market Analysis
● Competitive Analysis
● Target Market

● Unique Selling Proposition
● Marketing Initiatives
● Marketing Channels
● Measurements & KPIs
● Budget

Each section includes instructions for filling it out. You can remove sections, add
sections, and move things around to suit your business’ needs. For more complete
guidance, be sure to check out our companion blog post on How to Write a
Marketing Plan.
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[Company Name]

Marketing Plan

[Date]

Points of Contact [Name]
[Title]
[Contact Information]

[Name]
[Title]
[Contact Information]
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Business Summary

[CompanyName]
[Company Name] is a [market category] company headquartered in [City, State]
with offices in [other office locations]. We provide [services or products] to [customer
types] who want to [customer goals].

OurMission
[Mission statement]

VITAL PRO TIP

Nomission statement? Noworries!

What is the purpose of your business? What problem are you trying to solve?
What’s your vision for the future?

Once you have your “why,” move on to your “how.” What concrete actions is your
company taking to achieve your purpose? Put the two together, and you have a
mission statement.

Contact us for help writing your company’s mission statement.
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OurMarketing Team Leaders

[Name] [Job title and brief bio]

[Name] [Job title and brief bio]

[Name] [Job title and brief bio]

Executive Summary

Overview
[Write a compelling introduction setting the stage for your marketing plan. Treat this
section as a short, engaging narrative that tells the story of where your company
stands, where it’s going in the next year, and what role marketing will play in that
journey.]

Market Summary
[Give a brief overview of the state of the market and your company’s competitive
position, drawing on insights from the Market Analysis section of your marketing
plan.]

Customer Summary
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[Buyer
Persona
Name]

Awareness:
● [Problem or

challenge
they face]

● [Information
source]

Consideration:
● [Question

they need
answered]

● [Question
they need
answered]

Decision:
● [Reason to

choose your
brand]

[Buyer
Persona
Name]

Awareness:
● [Problem or

challenge
they face]

● [Information
source]

Consideration:
● [Question

they need
answered]

● [Question
they need
answered]

Decision:
● [Reason to

choose your
brand]

Goals & Strategies

Goal: [Summarize goal] Strategy: [Briefly describe how you will
achieve your goal]

Goal: [Summarize goal] Strategy: [Briefly describe how you will
achieve your goal]

Goal: [Summarize goal] Strategy: [Briefly describe how you will
achieve your goal]

[Add more rows by right-clicking a cell, then selecting
Insert > Rows Above / Rows Below]
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Budget Breakdown

[Initiative Name] $/month

[Initiative Name] $/month

[Initiative Name] $/month

[Add more rows by right-clicking a cell,
then selecting Insert > Rows Above /
Rows Below]

Total Monthly Budget $/month

Conclusion
[Wrap up your executive summary with a few sentences to encourage your audience
to read the entire plan.]
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Business Goals

[Company Name] is focused on [overarching business goal] in [year]. To enable us
to get there, the marketing department will set out to achieve the following:

[Goal 1]

Overview
[Example: We will acquire 10% more new
customers this year.]

Strategy
[Example: We will increase the number
of online appointments by 100%]

[Goal 2]

Overview
[Example: We will acquire 10% more new
customers this year.]

Strategy
[Example: We will increase the number
of online appointments by 100%]
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[Goal 3]

Overview
[Example: We will acquire 10% more new
customers this year.]

Strategy
[Example: We will increase the number
of online appointments by 100%]

VITAL PRO TIP

Writing great goals and strategies

Remember, your goals are what you set out to achieve and your strategies are the
high-level approaches you’ll take to get there. You’ll cover tactics, or the nitty-gritty
of how you’ll achieve your goals in the Marketing Initiatives section of your plan.

Write S.M.A.R.T. goals: Specific, measurable, attainable, realistic, and timely.
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Market Analysis

Overview
The [category] market in [geographical area] is a [$ amount] per year business, with
[number] [products] sold and [number] potential customers.

● Market trends: [Summarize current market trends]
● Market forces: [Summarize any economic or regulatory forces affecting the

market]
● Market forecast: [Summarize any predicted shifts in the market over the

coming year]

SWOTAnalysis

Strengths

● [What your company is good at
● What is working well
● What your satisfied customers

say about you]

Weaknesses

● [What is holding your company
back

● What needs improvement
● What customers are dissatisfied

with]
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Opportunities

● [How your company is positioned
to take advantage of market
trends

● What you’re doing better than the
competition

● Why future customers will choose
you]

Threats

● [What market trends and forces
threaten your company’s growth

● How competitors might
outperform you

● What potential customers might
choose over your company]

Competitive Analysis

[List your major competitors, along with relevant information about their brands,
positions in the marketplace, and how they compete with your company’s
marketing.]

Competitor Name CoreMessage Marketing Competition

[Company Name] [Slogan or USP] [Example:
● Blog ranks high for

keywords we want
to target

● Running paid ads
on our branded
keywords]

Strengths Weaknesses

[Example:
● Less expensive

product
● Bigger market

share]

[Example:
● Lower-quality

product
● High-pressure

sales environment]
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Competitor Name CoreMessage Marketing Competition

[Company Name] [Slogan or USP] [Example:
● Blog ranks high for

keywords we want
to target

● Running paid ads
on our branded
keywords]

Strengths Weaknesses

[Example:
● Less expensive

product
● Bigger market

share]

[Example:
● Lower-quality

product
● High-pressure

sales environment]

Competitor Name CoreMessage Marketing Competition

[Company Name] [Slogan or USP] [Example:
● Blog ranks high for

keywords we want
to target

● Running paid ads
on our branded
keywords]

Strengths Weaknesses

[Example:
● Less expensive

product
● Bigger market

share]

[Example:
● Lower-quality

product
● High-pressure

sales environment]

Buyer Personas

[Buyer Persona Name]
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Overview: [Write a brief introduction to the persona. Include
job title and function and relevant demographic and
psychographic details.]

“I want [the core need or desire your
company fulfills for this persona.]”

Where [Name]
Gets Information

[Ex: Google search] [Ex:
Word-of-mouth]

[Ex: Industry
newsletter]

Goals:
● [Goal 1
● Goal 2
● Goal 3]

Questions &Concerns:
● [Question 1
● Question 2
● Question 3]

Challenges & Pain Points
● [Pain point 1
● Paint point 2
● Pain point 3]

How [CompanyName] Helps:
● [Benefit 1
● Benefit 2
● Benefit 3]

[Buyer Persona Name]

Overview: [Write a brief introduction to the persona. Include
job title and function and relevant demographic and
psychographic details.]

“I want [the core need or desire your
company fulfills for this persona.]”

Where [Name]
Gets Information

[Ex: Google search] [Ex:
Word-of-mouth]

[Ex: Industry
newsletter]

Goals:
● [Goal 1
● Goal 2

Questions &Concerns:
● [Question 1
● Question 2
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● Goal 3] ● Question 3]

Challenges & Pain Points
● [Pain point 1
● Paint point 2
● Pain point 3]

How [CompanyName] Helps:
● [Benefit 1
● Benefit 2
● Benefit 3]

[Buyer Persona Name]

Overview: [Write a brief introduction to the persona. Include
job title and function and relevant demographic and
psychographic details.]

“I want [the core need or desire your
company fulfills for this persona.]”

Where [Name]
Gets Information

[Example: Google
search]

[Example:
Word-of-mouth]

[Example: Industry
newsletter]

Goals:
● [Goal 1
● Goal 2
● Goal 3]

Questions &Concerns:
● [Question 1
● Question 2
● Question 3]

Challenges & Pain Points
● [Pain point 1
● Paint point 2
● Pain point 3]

How [CompanyName] Helps:
● [Benefit 1
● Benefit 2
● Benefit 3]

VITAL PRO TIP

Creating Great Personas
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Check out our blog post, How to Create Buyer Personas for Your Brand for further
insights into researching, writing, and using buyer personas — with a free
downloadable template for creating more detailed personas.

Unique Selling Proposition

Our unique selling proposition explains what sets us apart from the competition, and
why our customers should choose us over the others.

[Example: Get more high-quality leads with the digital marketing
agency that focuses on your entire sales funnel — not just the “buy
now” crowd.]

VITAL PRO TIP

How toWrite Your USP
To create a powerful, effective USP, ask yourself these questions:

1. What do our customers want that we can provide?
2. What do we do better than the competition?
3. What is the most important benefit to your customers of choosing our

company over the competition?

Contact us for more help writing a USP that will make you stand out from the
crowd.
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Marketing Initiatives

To achieve our business goals of [goal 1], [goal 2], and [goal 3], our marketing team
will undertake the following projects and initiatives in [year].

[Initiative 1]

Overview
[Example: We will create a content
marketing calendar to support
production and publication of bi-weekly
blog posts.]

Goals
[Example:

● Rank organically on the first page
of the search engine results page
(SERP) for 10+ high-value
keywords

● Increase organic traffic to our
website by 50%]

Process
[Example:

● Perform keyword research
● Do competitor research on top

3–5 ranking blog posts
● Write copy
● Design graphics
● Publish
● Promote posts via email, social,

and/or PPC]
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[Initiative 2]

Overview
[Example: We will create a content
marketing calendar to support
production and publication of bi-weekly
blog posts.]

Goals
[Example:

● Rank organically on the first page
of the search engine results page
(SERP) for 10+ high-value
keywords

● Increase organic traffic to our
website by 50%]

Process
[Example:

● Perform keyword research
● Do competitor research on top

3–5 ranking blog posts
● Write copy
● Design graphics
● Publish
● Promote posts via email, social,

and/or PPC]

[Initiative 3]

Overview
[Example: We will create a content
marketing calendar to support
production and publication of bi-weekly
blog posts.]

18



Goals
[Example:

● Rank organically on the first page
of the search engine results page
(SERP) for 10+ high-value
keywords

● Increase organic traffic to our
website by 50%]

Process
[Example:

● Perform keyword research
● Do competitor research on top

3–5 ranking blog posts
● Write copy
● Design graphics
● Publish
● Promote posts via email, social,

and/or PPC]

Marketing Channels

We will reach our future customers on the following channels in order to drive traffic
to our site, generate leads, increase brand awareness, and establish thought
leadership in our industry:

[Example: Google Search Ads]

Goals [Examples:
● Increase website traffic
● Generate early-stage leads]
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Metrics [Examples:
● Click rate
● Cost per conversion]

[Example: IndustryWebsite]

Goals [Examples:
● Brand awareness
● Thought leadership
● SEO via link-building]

Metrics [Examples:
● Page views
● Engagement & interactions
● Page rank of link target]

[Example: Social Media Platform]

Goals [Examples:
● Brand awareness
● Sales]

Metrics [Examples:
● Impressions
● Engagement & interactions
● eCommerce store visits
● Cart fills]
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Measurement & KPIs

During [year], we will track data and report monthly on the following KPIs:

[Example: SEO]

KPIs [Examples:
● Organic page traffic
● Site visibility

● Keyword rankings
● Organic sessions
● Organic

click-through-rate]

Benchmark [Insert benchmark values for each of the KPIs you’ll measure and
report on.]

Goals [Insert growth goals for each of the KPIs you’ll measure and report
on.]

[Example: SEO]

KPIs [Examples:
● Organic page traffic
● Site visibility

● Keyword rankings
● Organic sessions
● Organic

click-through-rate]

Benchmark [Insert benchmark values for each of the KPIs you’ll measure and
report on.]
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Goals [Insert growth goals for each of the KPIs you’ll measure and report
on.]

[Example: SEO]

KPIs [Examples:
● Organic page traffic
● Site visibility

● Keyword rankings
● Organic sessions
● Organic

click-through-rate]

Benchmark [Insert benchmark values for each of the KPIs you’ll measure and
report on.]

Goals [Insert growth goals for each of the KPIs you’ll measure and report
on.]

[Example: SEO]

KPIs [Examples:
● Organic page traffic
● Site visibility

● Keyword rankings
● Organic sessions
● Organic

click-through-rate]

Benchmark [Insert benchmark values for each of the KPIs you’ll measure and
report on.]

Goals [Insert growth goals for each of the KPIs you’ll measure and report
on.]

[Example: SEO]

KPIs [Examples: ● Keyword rankings
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● Organic page traffic
● Site visibility

● Organic sessions
● Organic

click-through-rate]

Benchmark [Insert benchmark values for each of the KPIs you’ll measure and
report on.]

Goals [Insert growth goals for each of the KPIs you’ll measure and report
on.]

Budget

During [year], [Company Name] will allocate [%] of last year’s revenue toward
marketing initiatives, for a total marketing budget of [$].

Expense Category Estimated Cost

[Category]

[Category]

[Category]

[Category]

[Category]

[Add more categories by right-clicking
a cell, then selecting Insert > Rows Above
/ Rows Below]

Total [Total Marketing Expense for the Year]
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Need HelpWriting YourMarketing Plan?
Check out our blog post on How toWrite aMarketing Plan for more detailed
instructions of each step.

OR

Get In Touch!
Contact us online to start the conversation about how we can help write and execute
a marketing plan that will enable your business to meet its goals, grow its revenues,
and beat the competition.

Contact Us
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